David Brider (davidbrider) wrote,
David Brider
davidbrider

Pew pew

So, the good news - Elite Dangerous is now out for the Mac.

The bad news - although my hardware is, as far as I can tell, up to it, it'll need an update of the OS - I'm still running 10.7.5 (Lion), it needs 10.10.3 (Yosemite). I probably ought to upgrade at some point anyway, but I just don't want to risk accidentally losing anything, y'know, important...

Oh, and speaking of pew pew...

Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic
  • 0 comments